Start a new topic

Install command isn't executed when calling the command API

We're trying to set up a continuous deployment workflow, but we're running into an API issue. Our calls to the command API to install the app aren't triggering the app installation. I've attached the request we sent to the API, and I was hoping you can take a look and let us know how to resolve the issue. 


Hi Darrell,

Above API request body and URL looks good and should be working fine if you provide valid authorization (API key) along with the request. For this, you'll need to generate it from dashboard.

Onto dashboard traverse to -> API Key Management -> Create Key -> Generate Token -> Copy that key and provide it as authorization param which you can append in Header of the request.

  • Key Authorization
  • Value : Bearer <Your-API-Key>

Also, do let us know the response error you're getting after sending this request.

Hope this helps.



Hi Nilankita, 

I receive a successful response, however, the install wasn't triggered.

(20.6 KB)

Hi Darrell,

Thanks for posting response. I can see apps installed onto both of your devices already.

Can you let me know the time when you tried this and got above response, I'll check at what time it got installed onto device. Or if possible provide us video including API call and at the same time changes reflected on device screen.

Kind regards,



Below is a link to the video you requested.  I also attached the response.

  1.  I deleted the previous APK's for clarity.
  2.  I generate a new build using our CD tool, which uploads a new APK to Bitrise using the esper file upload API. 
  3. I grab the app version ID from the upload response and pass it to the command API. I received a successful response; however, the app version ID wasn't installed. 

(24.5 KB)

Additionally, you can see that the app ID that was sent in the request is not in the response.   

See screenshot:

Following up on this.  Any update?

Hi Darrell,

Apologies for the delay.

Based on the logs from one of the your device, I can see installation failure on 12th Feb, stating error- INSTALL_FAILED_UPDATE_INCOMPATIBLE. 

That's why application upgrade has failed with reported error "Package com.proteus.proteuskiosk signatures do not match previously installed version", which in turn ignores app installation for this newly built APK.

Can you please either build new APK with same signatures or uninstall existing app(may be app is not uninstalled as mentioned by you in comment from 12th Feb.)

As you got success response, that means this command is being processed by the device and don't states that the end results from device end if its installed or not.

Also, try installing same APK via console which you tried using API, it should result into same error. Please refer similar error posted here

Kind regards,


Login or Signup to post a comment